Switch to standard view 
  Sybase logo
 
 
 



Support for Multiple Versions of PowerBuilder (7.x and 8.x) in EAServer

PowerBuilder 7.x and 8.x runtime libraries can co-exist in EAServer. Components developed and deployed using these versions can be in use at the same time on the server. Sybase recommends using the same version number and build number of the PowerBuilder runtime libraries for the component and the client. This is a requirement when data being passed between the component and client is PowerBuilder-specific and subject to change between builds of PowerBuilder, such as the DataWindow BLOB associated with the GetFullState and SetFullState functions.

However, if the data being passed is of a primitive datatype or datatypes, or is a standard CORBA object such as ResultSet, then PowerBuilder 7 clients should work with PowerBuilder 8 components, or vice versa.



Back to Top
© Copyright 2010, Sybase Inc.