Switch to standard view 
  Sybase logo
 
 
 



Notice from Sybase to Customers:
Support for Using PowerBuilder and Oracle

This document describes PowerBuilder interoperability with Oracle and associated PowerBuilder drivers.

PowerBuilder version Connects to: Using this driver Notes
PowerBuilder 12.5/12.5.1/12.5.2 .NET and Classic Oracle 9.2.0.4 pbo90125.dll  
Oracle 10.2.0.3 pbo10125.dll  
Oracle 11.2.0.1.0 pbora125.dll  
PowerBuilder 12.1 (build 6950 and after) .NET and Classic Oracle 9.2.0.4 pbo90120.dll  
Oracle 10.2.0.3 pbo10120.dll  
Oracle 11.2.0.1.0 pbora120.dll  
PowerBuilder 12 and 12.1 .NET and Classic Oracle 9.2.0.4 pbo90120.dll  
Oracle 10.2.0.3 pbo10120.dll  
Oracle 11.1 pbora120.dll  
PowerBuilder 11.5.1 and 11.5 on Windows Oracle 9.2.0.4 pbo90115.dll  
Oracle 10.2.0.3 pbo10115.dll  
Oracle 11.1 pbora115.dll  
PowerBuilder 11 (build 7549) and higher on Windows Oracle 8.1.7 pbo84110.dll  
Oracle 9.2.0.4 pbo90110.dll  
Oracle 10.1.0 pbo10110.dll  
Oracle 10.2.0.3 pbo10110.dll Oracle 10.2.0.3 and higher supports Vista
PowerBuilder 11 on Windows (GA Version) Oracle 8.1.7 pbo84110.dll  
Oracle 9.2.0.4 pbo90110.dll  
Oracle 10.1.0 pbo10110.dll  
Oracle 10.2.0 pbo10110.dll  
PBVM 11 (build 6525) with EAServer on Solaris and Linux Oracle 8.1.7 libpbo84110x.so  
Oracle 9.2.0.4 libpbo90110x.so  
Oracle 10.2.0 libpbo10110x.so  
PowerBuilder 10.5.2 and EAServer on Windows Oracle 8.1.7 pbo84105.dll  
Oracle 9.2.0.4 pbo90105.dll  
Oracle 10.1.0 pbo10105.dll  
Oracle 10.2.0.3 pbo10105.dll Oracle 10.2.0.3 supports Vista
PowerBuilder 10.5.1 and EAServer on Windows Oracle 8.1.7 pbo84105.dll  
Oracle 9.2.0.4 pbo90105.dll  
Oracle 10.1.0 pbo10105.dll  
PBVM 10.5.1 (build 6021) on Solaris or Linux Oracle 8.1.7 libpbo84105x.so  
Oracle 9.2.0.4 libpbo90105x.so  
Oracle 10.1.0 libpbo10105x.so  
PBVM 10.5.1 (build 6021) on AIX Oracle 8.1.7 libpbo84105x.so.a  
Oracle 9.2.0.4 libpbo90105x.so.a  
Oracle 10.1.0 libpbo10105x.so.a  
PowerBuilder 10.5 and EAServer on Windows Oracle 8.1.6 pbo84105.dll  
Oracle 8.1.7 pbo84105.dll  
Oracle 9.0.1 (or higher) pbo90105.dll  
Oracle 10.1.0 pb010105.dll  
PBVM 10.5 on Solaris Oracle 8.1.7 libpbo84105x.so  
Oracle 9.2.0.4 libpbo90105x.so  
Oracle 10.1.0 libpbo10105x.so  
PowerBuilder 10.2 (Build 7516 or higher) and EAServer on Windows Oracle 8.1.6 pbo84100.dll  
Oracle 8.1.7 pbo84100.dll  
Oracle 9.0.1 pbo90100.dll Unicode support for nchar and nvarchar2 datatypes
Oracle 9.2.0.4 pb090100.dll Unicode support for nchar and nvarchar2 datatypes
Oracle 9.2.0.4 pb010100.dll Unicode support for nchar and nvarchar2 datatypes
Oracle 10.1.0.2 pb010100.dll New feature support for Binary_double and Binary_float datatypes, terabyte-size support for CLOB and NCLOB, unicode support for nchar and nvarchar2 datatypes.
PBVM 10.2 (build 7516) on Solaris for EAServer 4.2.3 and EAServer 5.2 Oracle 8.1.7 libpbo84100x.so  
Oracle 9.2.0.4 libpbo90100x.so nchar and nvarchar not supported
Oracle 10g libpbo90100x.so nchar and nvarchar not supported
PBVM 10.0.1 (Build 5502) on Linux for EAServer 5.2 Oracle 8.1.7 libpbo84100x.so  
Oracle 9.2.0.4 libpbo90100x.so  
PowerBuilder 10 and EAServer on Windows Oracle 8.1.6 pbo84100.dll  
Oracle 8.1.7 pbo84100.dll  
Oracle 9.0.1 pbo90100.dll  
Oracle 9.2.0.4 pbo90100.dll Oracle 9.2 new features are not supported
Oracle 10g pb090100.dll Oracle 10g new features are not supported


Back to Top
© Copyright 2010, Sybase Inc.